[Help] Cant connect with server

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Everthing is ok, creating accounts looks nice when ODBC says "succesful", server in-game bar is showing. Accounts can be created but i cant login.

In MuMaker i see my 3 created accounts but i cant connect to the server.
Everything is runned on local so 127.0.0.1.

Thanks anyway!
 

Damian

Team Member
Joined
Jun 12, 2008
Messages
621
Reaction score
582
What means "I can't login"? Do you receive any error message?
 

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Im able to make an account with Account Creator (MD5), then after making it i got information from GS that account was created.

Next im running client (127.0.0.1 - like in MuServer) and clicking on server list, then after typing the login and password i got massage that "Password incorrect".

Tried 5 times.
 

Damian

Team Member
Joined
Jun 12, 2008
Messages
621
Reaction score
582
This means that you have problem with MD5. Your joinserver is probably bugged or is not using MD5 encryption for the passwords. Try changing your joinserver with another one using MD5.
 

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Maybe i can try use this JoinServer from files thread but anyway, when im looking the soulution i just open the dat.MEMB_INFO table and there was only one user registered correctly, rest of them got passwords in Chinese font.
 

Damian

Team Member
Joined
Jun 12, 2008
Messages
621
Reaction score
582
I think that you dont make difference between md5 encrypted passwords and plain text passwords. You should check if your joinserver is using md5 or not. If not you should create your accounts without md5 password encryption.
 
  • Like
Reactions: Bydlak

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
After the wizard of removing MD5 - Dont work any editor.
After the wizard of adding MD5 - Same.

Dunno what fuckd up...
 

Deadman

Banned
Joined
Mar 17, 2014
Messages
323
Reaction score
279
1. Remove MD5 from the database table MEMB_INFO:
As i remember you should design the MEMB_INFO table and change
memb_password from var-smth (50) to varchar 10. (not sure tho..)
2. Replace join server with non-md5 one. (I will attach it here.)
3. Use Czf editor or MuMaker and select MD5 OFF

Don't forget the thanks button mate.
 

Attachments

  • Joinserver MD5 and not MD5.rar
    285.9 KB · Views: 130
  • Like
Reactions: Bydlak

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
DeadmanWonderland thanks for reply. Im going to run this files on Virtualbox 32bit, just want to test some of my progress with map editing. I'll make it as you say and ill give you anserw what is going on.

Thank you for helping me guys! Giving "Thanks" and wait for more progress!
 

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Nothing helped me with this shit, even SQL Server change. Maybe someone just want to Help me via TeamViewer? Got Virtualbox, everthing is on, server is working but got problem with registering users...

Info from MuMaker:
String or binary data would be truncated.
The statement has been terminated


Ingame:
Bad password, account valid

In-SQL MEMB_INFO Table:
Chinese passwords (created with Account Creator MD5)
 
Last edited:

Deadman

Banned
Joined
Mar 17, 2014
Messages
323
Reaction score
279
Info from MuMaker:
String or binary data would be truncated.
The statement has been terminated
This is from MD5!!!! you do something wrong ,md5 is the problem.
 

knif3r

Active Member
Joined
Jan 29, 2012
Messages
349
Reaction score
97
I had similar problem so did you tried with running this script in query analizer :
Code:
UPDATE VI_CURR_INFO
SET ends_days = '2005', check_code = '1', memb_name = '123132', memb_guid = '1', sno__numb = '1', Bill_Section = '6', Bill_Value = '3', Bill_Hour = '6', Surplus_Point = '6', Increase_Days = '0'
This should fix an error known as : No Charge Info but since you didn't mentioned it did you also try to install a website and register account via the website? You can try with MuWeb for example because it use md5 and remove it after you are done if you prefer anything else. Therefore if it doesn't work again I would advice you to remove MD5 from database or use other server files.

[Guide] How To remove md5 from Databases


Info from MuMaker:
String or binary data would be truncated.
The statement has been terminated

Go to Enterprise Manager - ServName - Database - MuOnline - Tables - Memb_info
Right Click - Design Table
then:
7741613O.png
 
Last edited:
  • Like
Reactions: Bydlak

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
knif3r, thanks for reply. After work i'll try to run account maker v'ia website, if nothing change i'll delete the files, clear ODBC and DB and make everything without MD5 this time.

What about memb_pwd? I got nvarchar (restored), not varchar like on the pic.
*same _id, _name, this columns got nvarchar after restoring.

PS. Which website CMS is most stable and safe for this type of files? (MD5 on 'we will try) 97d+99i (DarkSteam.)
 
Last edited:

ivowe3

Wiki
Joined
Apr 1, 2009
Messages
1,217
Reaction score
1,277
md5 OFF for 97d+-- Versions.

Easy way for understand your password is md5 or not is:

Open SQL: MuOnline Database
On table MEMB_INFO right click and select Design table
Looking for memb_pwd if it is varchar MD5=OFF if it is varbinary MD5=ON
 
Last edited:

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Oh guys, i got my account created via MuMaker "thanks for knif3r.

But got another problem - my password and login in MEMB-INFO is correct but i can login in-game says wrong password.
 

ivowe3

Wiki
Joined
Apr 1, 2009
Messages
1,217
Reaction score
1,277
i got nvarchar not varchar, maybe this is difference.

make it varchar and problem will be solved. i will give you eximple for varchar and nvarchar

for varchar when your password is "asdasd" your password still "asdasd" if you have nvarchar password your password will be "asdasd(interval)(interval)(interval)(interval)" have intervals after password.

same as memb___id make it varchar

You can find me on skype: ivowe3
 

knif3r

Active Member
Joined
Jan 29, 2012
Messages
349
Reaction score
97
Trust ivowe3 and make memb_id and memb_pwd to varchar by default it will set "varchar 50" change 50 to what you want the lenght of accound id's and passwords to be. For example 10 will put a limit of 10 characters for an account name and pwd.
 

Bydlak

New Member
Joined
Jun 5, 2011
Messages
22
Reaction score
1
Ok guys, everything works but... cant connect to server.
Click (Server) Click nexttime (Server), typing login and password and... nothing happening. The bar is loading and bah, password or account invalid.

Maybe someone just want to TeamView it? :p
Fuck, i need files only for map editing without it i cant set an attribute for each map...